CHAPTER

FOUR

WHAT’S NEW IN THIS VERSION?

FLOW-3D v11.2.0 continues to streamline engineers’ simulation workflows by enabling them to more quickly set
up simulations, avoid common errors, identify and enter missing data, and postprocess results to produce critical and
useful information faster. Some of the new features in FLOW-3D v11.2.0 are described below.
Important: All input files that were created in previous versions of FLOW-3D will need to be checked for deprecated
parameters and updated. This can be done by loading the input file into the user interface, at which point the automatic
file converter will updated the file and write a log describing the changes without altering the original file. However,
the file converter in the user interface may not be able to update all parameters in input files that are several versions
older than FLOW-3D v11.2.0, so some older input files may require manual updating.

4.1 FLOW-3D
4.1.1 Usability
1. Closing gaps in geometry: Small gaps in the geometry can result from design tolerances and variations caused
by the conversion of CAD data to STL format. These gaps could just be a visual annoyance or could negatively
affect the solution. The user can now request the preprocessor to close such gaps by providing the tolerance in
terms of distance below which all gaps will be closed. A similar procedure can be applied to ‘thin skin’ caused
by mismatches between surfaces of different components that may appear for reasons similar to those for gaps.
See the Closing Gaps in Geometry section for more detail.
2. Input flag for NTOTAL and SIZE definition: A new input flag IF_SIZE has been added to distinguish
between using the total number of cells or the average cell size for a mesh block. The default setting uses the
average cell size. If an old input file is used where the total number of cells is defined, please make sure that the
IF_SIZE variable is set accordingly either in the Meshing & Geometry tab in the user interface or using a text
editor. See the Meshing section for more detail.
3. Conforming meshes: The conforming mesh capability has been extended so that an active computational region
of an arbitrary shape can be defined. This is achieved through the use of a new type of geometry component
called meshing component that defines a region in the computational domain, spanning both open and solid
volumes, to which a mesh block can conform. Meshes conforming to meshing components are available under
the Meshing tree once a meshing component has been added to the simulation. See the section on Meshing
components and Conform to meshing component for more detail.
4. Interactive geometry creation: Primitive geometry such as boxes, cylinders, and spheres can now be added
to simulations by interacting with existing geometry. For example, if a user wishes to add a cylinder at the
geometric center of another cylinder’s face, the Feature detection tool will automatically detect the center of the
cylinder’s face when the user clicks on it and adds a cylinder there. The geometry added interactively can also
be edited interactively. See the discussion of interactive geometry creation in the Primitives, Interactive edits,
Pointers, Valves, and History Probes sections of the Model Setup for more detail.
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5. Updated icon placement: The icons for all geometry creation have been moved to the Geometry listbox. The
icons for Baffles, History probes, Void/Fluid pointers, and Valves have moved to their respective listboxes as
well.
6. Flux Surface Icon: A new Flux Surface icon has been added on the left side of the Model Setup –> Meshing
& Geometry window. Flux Surfaces can be easily added to simulation from here. When a new flux surface
is added to a simulation, the porosity of the surface is automatically set to 1.0 and cannot be changed. This
functionality is intended to minimize accidental changes that would prevent the flux surface from being used as
designed. Baffles can also be made flux surfaces from the Baffles listbox but their porosity is initially set to 0.5
by default. When existing baffles are defined as flux surfaces and their porosity is set to 0.0, they are moved to
the flux surface listbox when the simulation is unloaded and reloaded. See the Flux surfaces section for more
detail.
7. Units on all variables: Units for all variables are now displayed on dialog boxes as well as in the variable trees
in listboxes. Units are only displayed if the system units or temperature units are defined for the simulation.
8. Boundary Conditions Icon: The boundary conditions for mesh blocks have been moved from the bottom of
the tree for each mesh block to a new listbox for boundary conditions. This listbox is displayed when the new
Boundary Conditions icon situated to the left of the Meshing & Geometry tab is clicked. See the Mesh Boundary
Conditions section for more detail.
9. Copy Boundary Conditions to other mesh blocks: By right-clicking on any boundary in the Boundary Conditions listbox and selecting Transfer boundaries to..., a dialog will appear displaying all the boundaries of all
the mesh blocks in the simulation. The user can then apply the boundary conditions of the selected boundary to
boundaries of other mesh blocks. See the Transferring boundary conditions section for more detail.
10. Auto-on Selected Data: A new option called Set Default Selected Parameters for Selected Data in Output is
available under Preferences. This option allows users to define which Selected data should always be output
when a simulation runs. See the Spatial Data section for more detail.
11. Component property sorting: Component properties in the Component Properties listbox are now sorted by
their Active/Inactive states. For example, component properties for physical models that are not activated are
displayed below properties for activated physical models.
12. Process kill option for |favor| and FE Meshing: An ability to kill FAVORTM and FE meshing processes has
been added to prevent run-away processes.
13. Accidental scroll wheel changes: Users will find that accidental changes made to combo boxes in trees are now
much less likely to happen as they must click in the combo box before making changes.

4.1.2 Accuracy and performance
4.1.2.1 Solver
1. Geometry processing using FAVORTM : The accuracy of combining multiple subcomponents and components
has been improved to eliminate the occurrence of small gaps and bumps on the surface of the geometry. This
is achieved by taking into account the relative orientation and location of the fractional volumes within each
computational cell. See the FAVOR section for more detail.
2. GMRES pressure solver: The convergence criterion of the iterative GMRES solver, which is the default solver
for pressure in compressible and incompressible flows, now provides a more robust solution for a wider range
of applications, including transient and steady-state flows across different time and space scales. The new solver
gives more consistent results across different hardware configurations, number of cores used and operating
systems. See the Convergence Criteria Options and Pressure Iteration Options sections for more detail.
3. Fluid-structure interaction and Thermal stress evolution models: The speed of the finite element (FE) structural solver has been improved by optimizing the data structures used in the iterative GMRES solver for stresses
and deformations. The gain in performance comes at a cost in memory usage, with the actual increase a function
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of the number of FE nodes. A new hybrid solver has been developed that allows the user to control the amount
of extra memory needed by defining it in the input file. See the Simulation section for more detail.
4.1.2.2 Remote Solving Improvements
1. General Improvements: The core engine of the remote solving tool has been significantly upgraded to improve
stability and reliability. Issues with downloads terminating without warning have been addressed.
2. Speed: The tool used to download results from remote servers to the client has been moved out of the graphical
interface to prevent detrimental effects on performance. With this new implementation, many remote results can
be downloaded simultaneously.
3. Leave Results on Remote: A new option under Preferences→Remote Simulation Preferences, has been added
to allow results to be left on remote servers. The new option Leave results on remote will leave the results on
the remote server until they are synced to the client.
See also:
See the Remote Solving Setup section for more detail.
4.1.2.3 Graphics
Many improvements have been made to the underlying graphics engine to improve performance and quality. One
immediate impact will be seen while working with large raster files in hydraulics simulations. Raster files with 30
million points can be handled with ease with reasonably good graphics cards (e.g., NVidia Quadro) and adequate (>
2Gb) video memory. Depth peeling has also been improved and can be turned on via the Tools menu in the Meshing
and Geometry tab when an adequate graphics card is available. The Perspective view, available from the View menu
on the Meshing and Geometry tab, has been improved to provide a more consistent view for a wide range of geometry
scales.
Object highlighting, which causes an object under the mouse cursor to be highlighted, has been modified so that the
entire object is now highlighted when the cursor is moved over it. This behavior is controllable from the Mouse Hover
Selection option under the Tools menu on the Meshing & Geometry tab. If Mouse Hover Selection is turned off, users
must double click on an object to highlight it.

4.1.3 Physical models
4.1.3.1 General Applications
1. Lagrangian Particle Model: The Lagrangian particle model has been completely revamped and its capabilities
have been expanded through the addition of multiple particle classes: marker, mass, fluid, gas and void particles,
each developed with specific applications in mind. Additional classes have been created to represent probes
and mass/momentum sources. User-defined particle classes are designed for adding customized features by
modifying the source code provided with the installation. The definition of particle classes for the new particle
model can be set up from the new Particles icon situated on the left side of the Model Setup –> Meshing &
Geometry window. See the Particles section for more detail.
2. Dynamic droplet model for dispersed phase flows: The two-phase drift-flux model has relied on the knowledge of a constant particle size in the dispersed phase. This limitation has been removed by the addition of the
dynamic droplet model that uses the concept of the critical Weber and capillary numbers to evaluate the particle
sizes based on the local flow conditions. This approach is suitable for modeling dispersed phases made of gas
bubbles or liquid droplets. See the Drift Flux section for more detail.

4.1. FLOW-3D
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3. Air entrainment model: The setting of the initial, boundary and source conditions for the entrained air content
in the fluid has been simplified and better exposed in the user interface, allowing the user to access these settings
in simulations with and without bulking. See the Air Entrainment section for more detail.
4. Fluid/wall contact time: The output for the fluid contact time with individual solid components has been
extended to include the contact time with all components. The calculation of the contact time is activated by
simply selecting Wall contact time in the Output tab. See the Wall Contact Time section for more detail.
5. Vents/valves: The user can now control when the flow of gas through vents stops based on the amount of fluid
#1 at the vent. For two-fluid liquid/gas flows, both fluids can now be vented up to a point, after which only gas is
vented - until the vent is completely blocked by fluid #1. See the Flow Vent and Valves sections for more detail.
6. Granular media model: A new input variable that defines the volume fraction of sand at loose packing has
been added, giving the user more flexibility when modeling granular flows. See the Granular Flow section for
more detail.
4.1.3.2 Water & Environmental Applications
1. Outflow boundaries with wave absorbing layers: The wave absorbing feature that uses geometry components
of the Wave Absorbing type has been complemented by the addition of wave absorbing layers or rectangular
shapes adjacent to outflow and continuative mesh boundaries. This addition greatly simplifies the definition of
wave damping regions in the computational domain. The more general approach of placing wave absorbing
components anywhere in the domain has been retained. See the Wave-absorbing Layer (Sponge Layer) at
Outflow Boundary section for more detail.
2. Mooring line model: The mooring line model has been extended to include the tearing of lines, using the
Minimum Breaking Load as a new attribute of a mooring line. This development allows mooring line ends,
either one or both, to move freely. Also, the requirement of at least one end of a mooring line to be attached to a
moving component has been removed; the model can be used without the presence of General Moving Objects.
See the Mooring Lines section for more detail.
3. Sediment transport and scour model: The accuracy and robustness of the sediment transport model have been
enhanced by reducing the mesh-dependence of the solution and by improving sediment mass conservation. The
angle of repose of packed sediment is now properly taken into account when calculating the packed bed slope.
See the Sediment Scour and Deposition section for more detail.

4.1.4 Customization
1. Intel FORTRAN compiler version 16.0: The compiler for the solver has been upgraded to version 16.0 of
Intel FORTRAN compiler. Users who take advantage of customizing the code should upgrade their compiler.
The new compiler will work with older FLOW-3D installations as well.
2. FORTRAN 90 format: The format of the FORTRAN source routines provided with installation has been
changed from FORTRAN 77 fixed-form style to the free-form FORTRAN 90 convention. Among other things,
this necessitated changing the source file extensions from *.F to *.F90. Customized source routines from the
previous FLOW-3D versions will need to be converted.
See also:
See the Customization section for more detail.

4.2 FlowSight
1. Non-inertial reference frame motion: Non-inertial reference frames (NIRF) are very useful for simulating
moving reference frames such as those found in satellite-based fuel sloshing problems. One of the limitations of
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the Analyze and Display panel in FLOW-3D is that the motion (translation and spinning) cannot be visualized.
FlowSight can now display NIRF motion per the actual translation and rotation experienced by the simulation.
See the Non-Inertial Reference Frame Motion section for more detail on the solver model.
2. Distance measurement tool: A very flexible distance measuring tool has been implemented to allow distances
between any objects (e.g., STLs, isosurfaces, 2D clips) to be measured.
3. Uniformly spaced vectors on non-uniform meshes: The ability to define stretched meshes in FLOW-3D can
lead to visualization issues when displaying velocity vectors. For example, if the mesh is highly concentrated
in one area, a uniform vector field can be completely obscured due to the high vector density whereas in other
areas the vector field may be sparse. In these cases, changing the vector display density doesn’t help since this
change is applied uniformly. A new option to display the vectors on 2D clips uniformly solves this problem.
This new option is available as Show on Uniform Grid under the Velocity Vectors option on 2D clips.
4. Dials and gauges: Two new annotations called dials and gauges are available under the Add quick shapes option
on the right-mouse menu item on any viewport. Dials are especially helpful for displaying simulation time when
the time output rate is highly non-linear. For example, consider the case of a shot-driven HPDC filling where
the data output rate becomes very frequent due to the fast shot. Displaying the simulation time using a dial will
more clearly indicate the rapid frame rate than simply displaying time as text.
5. User defined color scales: Defining custom color scales is now very easy using the new custom color scale
tool.
6. XYZ coordinates on spline and streamline queries: The x/y/z coordinates corresponding to spline and streamline query values are now displayed in the query output dialog.
See also:
See the FlowSight user manual that is accessed from the Help→Local Help menu in FlowSight for more detail.

FLOW-3D and TruVOF are registered trademarks in the USA and other countries.
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